Rally Pac Issue

Tired of racKing your head? Tap in to someone else's experience, just asK for some advice.

Rally Pac Issue

Postby 99cobra » Sat Apr 22, 2017 8:07 pm

My car has an original 65 8K rally pac, just installed. The tach worked fine, the clock worked everything was great. After about 30 minutes of highway driving (~65 mph) the tach went from about 3200 RPM and pegged itself at 8,000 RPM. I let off the gas, no change in the tach. However if I depress the clutch the tach needle drops to about 5K. I ended up in a construction zone so my speed dropped to 45 mph for about 20 min. In that time the tach goes from 8K and starts reading correctly. It worked fine until I accelerated out of the construction zone, then it pegged itself at 8K again.

Any ideas about what is going on? Do you think I need to check the ground, or has the tach seen it's last days? I purchased the tach in November as a working unit, and finally the weather allowed me to test the car.

Thanks!
Dan
99cobra
AttraKted
 
Posts: 30
Joined: Sun Nov 09, 2014 6:39 pm

Re: Rally Pac Issue

Postby cobraboy » Sun Apr 23, 2017 12:09 am

Your tach can be rebuilt, I sent mine from the UK to Phil Severance in the US, he did a great job on budget and on time.
I would not bother with Tachman, he is rude and unhelpful.

Phil's contact
http://www.427galaxieregistry.com/phido ... tions.html
Image
13th April 1965 Dearborn K GT
User avatar
cobraboy
RidiKulous
 
Posts: 334
Joined: Fri Nov 25, 2011 10:59 am
Location: United Kingdom.

Re: Rally Pac Issue

Postby 99cobra » Sun Apr 23, 2017 6:23 am

Thanks for the reply, I will have to look into that.

Dan
99cobra
AttraKted
 
Posts: 30
Joined: Sun Nov 09, 2014 6:39 pm

Re: Rally Pac Issue

Postby proudKowner » Thu May 25, 2017 9:45 pm

Could a wire somewhere be shorting to ground at the higher speeds? Just a thought.


Kevin
proudKowner
Kommitted
 
Posts: 119
Joined: Thu Nov 29, 2012 9:35 pm
Location: SoCal

Re: Rally Pac Issue

Postby C6ZZKGT » Thu May 25, 2017 10:51 pm

proudKowner wrote:Could a wire somewhere be shorting to ground at the higher speeds? Just a thought.


Kevin


My thought would be that a wire shorting to ground for the tach would cause the car to stop running.

-Fred-
66 K GT Fastback Silver Frost / Black Pony Interior
66 K GT Fastback Signal Flare Red / Black Pony Interior
65 K Coupe Phoenician Yellow / Black Standard Interior
65 A Code 4 speed Ranchero
64 289 4 Speed Falcon Sedan Delivery
66 Corvette 427 Roadster
User avatar
C6ZZKGT
Klassic
 
Posts: 5823
Joined: Fri Nov 25, 2011 10:35 am
Location: Canyon Country, California

Re: Rally Pac Issue

Postby C6ZZKGT » Thu May 25, 2017 10:52 pm

Does this Kar still have an original dual point distributor?

-Fred-
66 K GT Fastback Silver Frost / Black Pony Interior
66 K GT Fastback Signal Flare Red / Black Pony Interior
65 K Coupe Phoenician Yellow / Black Standard Interior
65 A Code 4 speed Ranchero
64 289 4 Speed Falcon Sedan Delivery
66 Corvette 427 Roadster
User avatar
C6ZZKGT
Klassic
 
Posts: 5823
Joined: Fri Nov 25, 2011 10:35 am
Location: Canyon Country, California

Re: Rally Pac Issue

Postby 99cobra » Fri May 26, 2017 3:43 pm

Car does have the original dual point distributor. I don't think a wire is shorting at high speeds, even though the first time it corrected itself when I slowed down. The 2nd time it happened it stayed pegged at 8K even at low speeds and idle. Almost seemed that when the electronics in the Rally Pac heated up things got crazy.

I sent the rally pac off to Phil at Phidon Restoration, there seemed to be numerous problems with the tach after he tore it down. Based on that I am pretty sure it was a faulty tach. Already back in and wired up. It reads fine at idle, the test will be a long drive. I must say Phil's service was great and prices reasonable. If it ever stops raining in Chicago I will be able to take the car out and test the tach.

Fingers crossed!
Dan
99cobra
AttraKted
 
Posts: 30
Joined: Sun Nov 09, 2014 6:39 pm

Re: Rally Pac Issue

Postby C6ZZKGT » Fri May 26, 2017 3:55 pm

Let us know how it works out.

-Fred-
66 K GT Fastback Silver Frost / Black Pony Interior
66 K GT Fastback Signal Flare Red / Black Pony Interior
65 K Coupe Phoenician Yellow / Black Standard Interior
65 A Code 4 speed Ranchero
64 289 4 Speed Falcon Sedan Delivery
66 Corvette 427 Roadster
User avatar
C6ZZKGT
Klassic
 
Posts: 5823
Joined: Fri Nov 25, 2011 10:35 am
Location: Canyon Country, California

Re: Rally Pac Issue

Postby 99cobra » Sun May 28, 2017 7:05 am

Took the car out yesterday for a 30-40 minute drive. Tach worked great and no issues. It looks promising, and I am thinking it was an issue with the tach itself. It sure was nice having the rally pac in place, and working!

Thanks to everyone for the help, hopefully that solved it.

Dan
99cobra
AttraKted
 
Posts: 30
Joined: Sun Nov 09, 2014 6:39 pm

Re: Rally Pac Issue

Postby C6ZZKGT » Sun May 28, 2017 9:43 am

I am happy that everything worked out for you.

-Fred-
66 K GT Fastback Silver Frost / Black Pony Interior
66 K GT Fastback Signal Flare Red / Black Pony Interior
65 K Coupe Phoenician Yellow / Black Standard Interior
65 A Code 4 speed Ranchero
64 289 4 Speed Falcon Sedan Delivery
66 Corvette 427 Roadster
User avatar
C6ZZKGT
Klassic
 
Posts: 5823
Joined: Fri Nov 25, 2011 10:35 am
Location: Canyon Country, California


Return to Koncerns & Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest